Invalid user id. - 0

dbone58's Avatar

dbone58

22 Mar, 2020 07:36 PM

When logged in as Admin, I can go into the admin panel and create a poll. after creating the poll, I return to the main site. The poll is created but it says created by user unknown. ( see user unknown . jpg )

In my logs file I am getting an error ( see invalid user id . jpg )
Invalid user id. - 0
FILE - /home3/mysite/public_html/inc/utils.php [157] PHP - 7.3.13 (Linux) STACK #0 __construct called at [/home3/mysite/public_html/home.php:40] #1 control called at [/home3/mysite/public_html/home.php:69] #2 displayWhatsNew called at [/home3/mysite/public_html/home.php:94] #3 displayWhatsNewAll called at [/home3/mysite/public_html/home.php:276] #4 getUserDisplayName called at [/home3/mysite/public_html/home.php:599] #5 add called at [/home3/mysite/public_html/inc/utils.php:153]

I'm sure both are related ... I have been doing some digging to find the cause, but to no avail.
Matbe someone else has had this issue, and I cannot find that thread in here.. Thanks for any input or insight..

  1. Support Staff 1 Posted by Ryan Haudenschi... on 23 Mar, 2020 02:48 PM

    Ryan Haudenschilt's Avatar

    Actually polls do not have a created by user column. So it will always say it was created by 'unknown user'.

    That is just an old design issue. It's not really broken, just maybe unfortunate to see on the Whats new area.

    I think the bug is that the code doesn't handle this situation very well. I'll look into it and see if i can fix it.

    Thanks,

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac